Grand Theft Auto 4
подробнее об игре и системные требования
  
НАВИГАЦИЯ ИГРЫ

Grand Theft Auto 4: Net Script Hook {1.7.1.4 BETA} [1.0.1.0-1.0.7.0/1.1.2.0 EFLC]

Имя файлаscripthookdotnet.zip
Размер693 Кб
Добавилkrutish
Дата добавления
Скачиваний13778
Комментариев32
Понравилось22
Описание и инструкции

Grand Theft Auto 4 .Net Script Hook v1.7.1.4 BETA - позволяет подгружать при старте игры скрипты написанные на любом .Net языке (Пример: скрипт позволяющий в игре заправлять бензин).

Предназначен для игры Grand Theft Auto 4 версии 1.0.1.0, 1.0.2.0, 1.0.3.0, 1.0.4.0, 1.0.0.4, 1.0.6.0, 1.0.7.0 и Grand Theft Auto IV: Episodes from Liberty City версии 1.1.1.0 - 1.1.2.0...

Основные изменения:
- Исправлены все известные ошибки...
- Добавлена совместимость с GTA IV v.1.0.7.0 и EFLC v.1.1.2.0…
- Добавлено свойство « Game.CurrentEpisode»…
- К общему перечню оружия добавлены названия оружия из эпизодов TLAD и TBOGT…

Установка:
Скопируйте содержимое архива в корневую папку игры.

Установка скриптов:
Скопировать скрипты в папку "scripts"

Поддерживаемые форматы:
*.vb - обычные скрипты VisualBasic.Net
*.cs - обычные скрипты C#
*.net - скомпилированные скрипты на любом .Net языке
*.net.dll - скомпилированные скрипты на любом .Net языке

Для корректной работы .Net Script Hook необходимы установленные дополнения:
- Microsoft .Net Framework 4...
Ссылка: www.microsoft.com/downloads/details.aspx?display..
- DirectX (Обновить)...
Ссылка: www.microsoft.com/downloads/details.aspx?FamilyI..
- Microsoft Visual C++ 2010 Redistributable Package
Ссылка: www.microsoft.com/downloads/details.aspx?FamilyI..
- Любой AsiLoader
-> Alexander's AsiLoader(v 1.0.7.0-1.1.2.0 EFLC)
-> Xliveless (v 1.0.7.0-1.1.2.0 EFLC)
-> YAASIL
Нравится 22
Комментарии (32)
  • 0
    Спасибо,а на аси лоадер новый не мог бы ссылку кинуть?
  • 0
    krutish
    NAV1GATOR 72 нового пока нет, пользуйся старым, он подходит... Скоро Xliveless новый появится, я его на день позже залил...
  • 0
    krutish
    -><-
  • 0
    k1slim

    Игра не запускается,такую ошибку выдаёт,.Net Framework 4 и Microsoft Visual C++ 2010 Redistributable Package стоят..
    Что делать?
  • 0
    Спасиб а то с новым патчем и скрипты не пахали, а с русиком 1С будут пахать скрипты?
  • 0
    krutish
    iN1ck нет ScriptHook.dll не совместим с русской версией...
  • 0
    krutish
    k1slim

    УСТАНОВИ ЗАНОВО ПАТЧ 1.0.7.0 ИЛИ 1.1.2.0 ДЛЯ EFLC

    А ВООБЩЕ, ЧТО У ТЕБЯ ЗА СБОРКА ИГРЫ РЕПАК ИЛИ ЛИЦЕНЗИЯ, КАКАЯ ВЕРСИЯ ИГРЫ (КАКОЙ ПАТЧ), ПОСТАВЬ ВСЕ ДОПОЛНЕНИЯ ЗАНОВО ПО ВЕРХ ИГРЫ (Microsoft .Net Framework 4, DirectX, Microsoft Visual C++ 2010), ПРВЕРЬ СТОИТ ЛИ У ТЕБЯ Microsoft Visual C++ 2005 (он устанавливается во время установки самой игры - у лицензии)

    Лучше так, установил английскую версию игры, установи сверху Microsoft .Net Framework 4, затем патч 1.0.7.0 или 1.1.2.0 ДЛЯ EFLC, затем Net Script Hook 1.7.1.4 BETA
  • 0
    Плохо:(
  • 0
    УСТАНОВИ ЗАНОВО ПАТЧ 1.0.7.0 ИЛИ 1.1.2.0 ДЛЯ EFLC

    а кряк работает на 1.1.20 на эпизодах ?
  • 0
    k1slim
    krutish 16 - гиговая пиратка..
    Я не такой тупой,что бы пытаться запустить скрипт вместе с русиком от 1С(тем более этот русик у меня не прёт)
    Патч 1110...
    Microsoft Visual C++ 2005,Microsoft Visual C++ 2010 стоят(Поверх инсталеной игры ставились)
    Framework и DirectX последние..
    7 винда,новый патч пока ставить не собираюсь,ибо он УГ
    Но эта ошибка не из-за патча,т.к. старый .Net Script Hook(Не заточенный под новый патч)тоже выдавал эту ошибку
    Пробовал запустить на оригинале(Лицка от 1С,1004 патч,скрипты работают все(Хук заточен под все английские патчи,на оф. форуме подсмотрел) ),закончилось всё той же ошибкой..

    А,забыл сказать,скрипты у меня работают(Фёрст персон например,или нетив трейнер)
    Ещё варианты есть?
    Писал на официальную страницу хука,но даже автор не ответил(А постит он там часто)По ходу у них там менталитет такой,скриптописание обсуждают,а сунешься с ошибкой - фиг ответ получишь...
  • 0
    krutish
    k1slim ну все перепробывал, каких только ошибок сегодня не насмотрелся, но твоей так и не увидел... Попробуй всётаки установить новый патч, хуже с него не становится (кряки, трейнер и скрипты к нему подходят от прошлой версии)... Не получится снесёшь его, ты в этом смысле ни чего не теряешь...

    У меня всё отлично работает, я просто не знаю что и посоветовать...



    А попробуй ScriptHook.dll, поставить от той версии игры, в которую гамаешь...

    -><-
  • 0
    k1slim
    Собственно была бы у меня безлимитка,я бы давным давно скачал новый патч...
    Спасиб за хоть какую-то помощь,буду пытаться...
  • 0
    у меня не хочет качать... нажимаю на ссылку а он в поиск выкидываеть и выдаёт совпадение по имени на старый scriptHook = ((
  • 0
    krutish спасибо выручил! )
  • 0
    krutish
    Flacoon не за что...
  • 0
    ребят, подскажите что делать? Стоит гта 1.0.4.0. Поставал русик, машины, xliveless, ScriptHook.dll и т.д. В игре одинаковые машины ездят, в основном такси, ну вы в курсе. Что делать? RealTrafficSpawn1.02 и тому подобное ставил, толку ноль. Да и ~ нажимаю, консоль не вылазиет.
  • 0
    Гыыыы
    Поставил чистую пиратку,на нее патч 1.0.7.0,xliveless 1.0.7.0 и Script Hook этот,теперь игра вообще не запускается....
  • 0
    i082.radikal.ru/1007/14/d5dd3745095a.jpg

    Самое интересное, что фреймворк у меня стоит, причём я ставил и полный и тот, который сам определяет и качает из инета нужную 64 версию.
    Полная версия и для 86 и 64.
    Директ обновил, С++ поставил, не знаю уже, что делать

    Патч 1.0.0.4
    Проблема же в этом хуке, а он на этом патче должен работать
  • 0
    В чём может быть дело? Установлена ГТА 4, с пачтем (русским) 1.0.6.1, таблетка от Разор. Скинул в папку игры XLiveLess {0.9999b7} (поддержка русских патчей) [1.0.5.1/1.0.6.1 RU] и Net Script Hook {1.7.1.4 BETA} [1.0.1.0-1.0.7.0/1.1.2.0 EFLC], установил все обновы Microsoft .Net Framework 4, Microsoft Visual C++ 2010 Redistributable Package, DirectX (Обновить) (так как без данных обнов при нажатии на лауч ГТА выбивало ошибку ...не найдена ...dll, точно уже не помню какой то, но ясно было, что ошибка из-за не установленного Net Framework 4), после поскидывал всякие фитчи в скриптовую папку, но в игре ноль результата! НИодин скрипт не работает!
  • 0
    У меня проблема поставил этот ScriptHook на патч 1.0.7.0 игра при загрузке вылетает,установил всё что в верху написано непомогает.Мож кто знает в чём проблема
  • 0
    на патче 1.0.6.0 при входе выдаёт ошибку microsoft visual c++ runtime library runtime error, игра запускается но Net Script Hook не пашет. пробовал версии 1.6.1.2, 1.6.1.3, 1.7.1.4 изминений нет, установил Microsoft .NET Framework 4 И Microsoft Visual C++ 2010 Redistributable Package не помогло. на патче 1.0.4.0 предыдущии версии работали норм. кто что может посоветовать???

    P.S. возвращаться к патчу 1.0.4.0 не хочется
  • 0
    При попытке компиляции скрипта, на VC# 2008 Express, выдается ошибка: "Не удалось найти имя типа или пространства имен "GTA"". Ссылку на "ScriptHookDotNet.dll" вроде подключил, правда она помечена знаком "проблемы" (такой желтый треугольник со знаком восклицания).
    Помогите пожалуйста, очень надо!
  • 0
    у меня тожесамое что и у k1slim че только непробувал помогите
  • 0
    народ напишите плиз что нужно для того, чтобы поиграть с этим трейнером www.playground.ru/cheats/42720/ на эпизодах, у меня 1ый патч. перепробывал много всего и ничего не получается. заранее спасибо.
  • 0
    kjksz349
    установи второй патч 1.1.2.0
  • 0
    Вы уверены что этот нетскриптхук пашел на 1004 патче? я уже че только неперепробывал, выкидывает из игры после загрузки миссии...
    пробовал запускать игру без папки скриптов, толку ноль
  • 0
    Народ подскажите что мне надо делать нет не одного мода патч не знаю какой вроде 1.0.1.0 и что мне надо делать чтобы поставить какой нибудь мод??
  • 0
    есть ток тачи залитые и все
  • 0
    Так сам лично проверял на пиратке 1,0,7,0 всё работает отлично.
    сначала ошибка была: "MSVCR100.dll not found"
    почитал ReadMe нашёл:

    10. Troubleshooting
    If you get a "MSVCR100.dll not found" error, try installing the Microsoft Visual C++ 2010 Redistributable Package:
    www.microsoft.com/downloads/details.aspx?FamilyI..

    (кстати это в описании к файлу так же написано, что это нужно)

    Помогло)))) спасибо +10 за хороший рабочий плагин
  • 0
    я все установил выше сказанное когда запустилась игра у меня сверху в левом углу пишет error skript ..... пробовал разные ставить скрипты и на все так реагирует... что делать??
  • 0
    krutish
    Он говорил про русификатор от 1С, а не игру от нее, я сам на 7 патч такой русик ставил, вроде, должно пойти...
  • 0
    на win 8.1 и русской версии ГТА 4 1,0,6,1 выдаёт ошибку
    Имя события проблемы: BEX
    Имя приложения: GTAIV.exe
    Версия приложения: 1.0.6.1
    Отметка времени приложения: 4bd9f687
    Имя модуля с ошибкой: ScriptHook.dll_unloaded
    Версия модуля с ошибкой: 0.5.1.0
    Отметка времени модуля с ошибкой: 4c00493c
    Смещение исключения: 00027001
    Код исключения: c0000005
    Данные исключения: 00000008
    Версия ОС: 6.3.9600.2.0.0.256.4
    Код языка: 1049
    Дополнительные сведения 1: 7a94
    Дополнительные сведения 2: 7a9427f2eed69574a678e10af9c90a81
    Дополнительные сведения 3: 84f8
    Дополнительные сведения 4: 84f8e6f01b4a6cb39d38f55fb0949efd

    Microsoft .Net Framework 4
    - DirectX
    - Microsoft Visual C++ 2010 Redistributable Package - по ссылкам в шапке сходил, везде пишет что уже стоит более новая версия
    может что насоветуете?
B
i
u
Спойлер

Вы уверены что хотите удалить этот комментарий?